MoEngage Docs

SDK Configuration

This section describes the build configuration and library dependencies used by the SDK.

Build Configuration

Target SDK Version28
Compile SDK Version28
Minimum SDK Version16

Library Dependency

SDK is compiled with the version 28.0.0 version of support-compat and appcompat-v7
Though the SDK is compiled with version 28.0.0 it uses the version provided by the client app at run-time. SDK does not include the support library as a dependency.
Parts of the SDK is written in Kotlin and the SDK ships with 1.3.61 version of Kotlin. If your application already uses Kotlin you can choose to exclude the Kotlin dependency.

📘

This document contains the build configuration for the latest SDK version only. If you are using an older version of the SDK and want to know the build configuration please reach out to us at [email protected] or contact your Account Manager.

Updated 4 months ago

SDK Configuration


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.