Migration To Maven Central

JFrog recently announced that they are making important changes that will impact users of Bintray, JCenter. We as developers would not be able to publish new packages on Bintray after 31st March 2021 and existing packages wouldn't be available for use after 1st February 2022.
Checkout out the blog post for more details.

We at MoEngage have been publishing our Android SDK/artifacts to Jcenter for the past few years and have moved to publish artifacts to Maven Central. Going forward all the artifacts would be available via Maven Central only.

How does it affect you?

Since existing packages are available for download till 1st February 2022 the shutdown will not affect you immediately. Though we strongly recommend you migrate to the version published on maven central(11.0.04 or above) at the earliest to avoid any issues.

🚧

The versions mentioned below in the documentation is the latest version at the time of publishing this document(1st March 2021). Refer to the Release Notes of the respective framework.

Migration for 11.x.xx

If you are using the 11.x.xx version of the MoEngage SDK you would just need to change the version to 11.0.04 or above to move to maven central Artifacts.
Make sure you update the other unbundled/dependent MoEngage SDKs or modules(like Push Amp Plus, Push Templates, etc.) to the compatible version.
Below is the list of compatible versions for 11.0.04, 1st version on maven central.

ArtifactVersion
moe-android-sdk11.0.04
addon-inbox6.0.2
cards2.0.02
hms-pushkit2.0.02
push-amp-plus3.0.02
rich-notification2.0.03
geofence1.0.02

Migration for 10.x.xx

Update to the latest SDK version 11.0.04 or above. Since it would be a major version update there might be additional code changes required apart from changing the version number in your gradle file(s). Refer to the Updating to 11.x.xx document and Release Notes for more details.
Make sure you update the other unbundled/dependent MoEngage SDKs or modules(like Push Amp Plus, Push Templates, etc.) to the compatible version.

In case, you are not able to update to 11.x.xx due to some technical limitations or bandwidth issues we have uploaded the last 10.x.xx version along with the add-on modules on Maven Central. You can update to the below versions.

ArtifactVersion
moe-android-sdk10.6.01
addon-inbox5.3.1
cards1.2.01
hms-pushkit1.2.01
push-amp-plus2.2.01
rich-notification1.2.02

🚧

We strongly recommend you update to the latest version instead of 10.6.01 to take advantage of all the latest features/improvements/optimizations we have made.

Migration for below 10.x.xx

We recommend you update to the latest version, we will not be publishing/moving 9.x.xx or below to maven central. Since you would be updating 2 major versions we recommend you go through the documentation and update accordingly.

Cross-Platform Frameworks

MoEngage provides support for a number of cross-platform frameworks like React-Native, Flutter, Unity, Cordova, etc. Our Cross-Platform frameworks are dependent on the above-mentioned native(Java/Kotlin) Android SDK and equally affected by the Jcenter shutdown. We have updated our Cross-Platform plugins or packages to use artifacts published on Maven Central instead of Jcenter.
Below are the latest version of the plugins.

Framework NameVersion
React-Native7.0.0
Flutter3.0.0
Flutter Inbox2.0.0
Cordova7.0.0
Unity2.0.0

The above version is built on top of 11.x.xx and we strongly recommend you to use the above versions or above.

In case, you are not able to update to 11.x.xx due to some technical limitations or bandwidth issues we have uploaded the last 10.x.xx version along with the add-on modules on Maven Central. You can update to the below versions. These versions are built on top of 10.6.01 the 10.x.xx version on Maven Central.

Framework NameVersion
React-Native6.1.7
Flutter2.0.3
Flutter Inbox1.0.2
Cordova6.1.4
Unity1.3.1

Segment Integration

We recommend you migrate to the version published on maven central(5.1.00 or above) at the earliest to avoid any issues.

Migration for 5.x.xx

If you are using the 5.x.xx version of the MoEngage SDK you would just need to change the version to 5.1.00 or above to move to maven central Artifacts.
Make sure you update the other unbundled/dependent MoEngage SDKs or modules(like Push Amp Plus, Push Templates, etc.) to the compatible version.

Migration for 4.x.xx

Update to the latest SDK version 5.1.00 or above. Since it would be a major version update there might be additional code changes required apart from changing the version number in your gradle file(s). Refer to the Updating to 11.x.xx document and Release Notes for more details.
Make sure you update the other unbundled/dependent MoEngage SDKs or modules(like Push Amp Plus, Push Templates, etc.) to the compatible version.

In case, you are not able to update to 5.x.xx due to some technical limitations or bandwidth issues we have uploaded the last 4.x.xx version along with the add-on modules on Maven Central. You can update to the below versions.

ArtifactVersion
moengage-segment-integration4.3.01
addon-inbox5.3.1
cards1.2.01
hms-pushkit1.2.01
push-amp-plus2.2.01
rich-notification1.2.02